Back to overview
Degraded
Pingocard Web App is down
May 21 at 06:50am IST
Affected services
Pingocard Web App
Resolved
May 21 at 07:20am IST
Pingocard Web App recovered.
Affected services
Pingocard Web App
Created
May 21 at 06:50am IST
Pingocard Web App is degraded.
Affected services
Pingocard Web App