Back to overview
Degraded

pingocard.com/xxxx is down

May 07 at 11:52pm IST
Affected services
pingocard.com/xxxx

Resolved
May 08 at 12:15am IST

pingocard.com/xxxx recovered.

Created
May 07 at 11:52pm IST

pingocard.com/xxxx is degraded.