Back to overview
Degraded

Pingocard Analytics and Pingocard Website are degraded

Apr 29, 2025 at 5:22am UTC
Affected services
Pingocard Analytics
Pingocard Website

Resolved
Apr 29, 2025 at 5:40am UTC

Pingocard Website recovered.

Updated
Apr 29, 2025 at 5:34am UTC

Pingocard Analytics recovered.

Created
Apr 29, 2025 at 5:22am UTC

Pingocard Analytics and Pingocard Website are degraded.